close
企業趨勢資訊保安

醫管局更新 IE 反使醫院運作受阻 再證軟件兼容問題不容忽視

相信大部分讀者現在都會嫌 IE 慢,上網時會用 Chrome 或者 Firefox ,但原來政府的電腦軟件仍然依賴 IE 運作。當然,只要軟件運行正常用 IE 也不是問題,但最近醫管局把 IE 升級,結果軟件無法正常運作,使不少公立醫院的醫護人員的工作受阻。

hospital

 

升級 IE 11 反使軟件無法正常運作

據指於上月三十日大約四時半,資訊科技及醫療訊息部接獲醫院前線人員通知,指他們無法登入臨床管理系統(CMS)。除此之外,住院病人藥物處方系統(IPMOE)、病人管理系統(PAS)及放射科訊息系統(RIS)也受影響。

經檢查後,原來問題是由於 IE 9 更新到 IE 11,使醫管局自行研發的軟件無法正常運作。結果醫護人員無法查閱病歷紀錄、X光服務、開藥及派藥系統。幸好之後是國慶假期,大部分門診休息,所以未有發生重大的問題。事後有關部門已趕緊搶修,但到翌日凌晨三時仍未解決,最後只有直接影響病人服務的護士站以及假期普通科門診的電腦系統能夠修複。

後來醫管局發言人確定所有受影響電腦的軟件程式運作正常。但醫管局行政總裁梁栢賢認為事態嚴重,已要求資訊科技及醫療訊息部主管張毅翔交代。

 

升級要注意兼容

雖然新版本的軟件會提供更多的功能,但使用者亦要留意軟件的兼容性。Unwire.Pro 早前也是報導過有關升級到 Windows 10 可能遇到的問題,因此作出更新決定時應深思熟慮。而 F-Secure 大中華及南韓區總監李力恒也指出,企業在更新電腦前應反覆測試,並要預先估計更新後出現的問題,及早擬定解決方法。

就這次事件,立法會資訊科技界議員莫乃光也指出,為了防止錯誤重複發生,醫管局應調查是軟件更新指引出錯,還是個別人員無跟隨指引導致問題發生。

 

舊版 IE 過時 更新無可厚非

然而,撇除「沒有事先評估更新帶來的影響」這個錯誤,其實更新是應該的,特別是 IE9。如果讀者時常留意 Unwire.Pro 的報導,應知道 IE9 已經十分過時。

首先,微軟一早已致力清除舊版 IE 。早在 2014 年,微軟已宣布逐漸停止舊版 IE 的支援, Windows 7 和 Windows 8 等都必須使用最新的 IE ,才能繼續使用 Microsoft 的安全性更新服務;第二,在 Windows 10 起微軟開始推出全新的瀏覽器 Edge,Edge 將終止支援 IE 的 10 多種專屬技術,如歷史悠久的 Active X、BHO、VBScript、Document modes、 Vector Markup Language等,IE 其實已在步入歷史了。

 

Tags :IEInternet Explorer
Dennis Ma

The authorDennis Ma

為香港讀者分享各種 IT 新聞及趨勢,如企業動態、保安消息(勒索軟件、程式漏洞等)、未來科技(AR、VR、3D打印等。)、電子商貿;亦專門分享 SEO、網頁設計、社交平台推廣等心得。

Leave a Response